Query failures for select organizations connected to Snowflake
Incident Report for Sigma Computing
Postmortem

Sigma Engineering has completed the postmortem of this incident. A Root Cause Analysis (RCA) is available on the Sigma Community site: Postmortem for Oct 03, 2023 Incident: Query failures for select organizations connected to Snowflake

Posted Oct 17, 2023 - 21:17 UTC

Resolved
We have received confirmation from Snowflake that they've rolled back globally for all impacted users. At this time we believe full functionality has been restored and expect all Snowflake users can now access their workbooks and data warehouse connections.

Impacted Cloud Regions & Services: Snowflake connections for a subset of Sigma users hosted on GCP and AWS

User Experience: Affected users can now access their workbooks and data warehouse connections.

Incident Start Time: Approximately 13:00 UTC October 3, 2023

Incident End Time: Approximately 18:03 UTC October 3, 2023

We will perform a root cause analysis (RCA) and publish our findings in a postmortem note to the Sigma Community site in coming days.
Posted Oct 03, 2023 - 18:48 UTC
Update
We were able to to reproduce locally and issue is fixed in our environment after Snowflake rolled back a server change on their side. We're now working with them to apply the rollback to all accounts.
Posted Oct 03, 2023 - 16:45 UTC
Update
We are investigating an issue with queries resulting in the error message "Bad request; operation not supported." We have engaged with Snowflake support and are treating this as our highest priority. Our apologies for any inconvenience caused.
Posted Oct 03, 2023 - 14:43 UTC
Investigating
We are investigating an issue with queries resulting in the error message "Bad request; operation not supported." We are treating this as our highest priority. Our apologies for any inconvenience caused.
Posted Oct 03, 2023 - 13:41 UTC
This incident affected: GCP (Sigma - GCP (US)) and AWS (Sigma - AWS (US)).