Workbooks containing Snowflake Semantic Views fail to load

Incident Report for Sigma Computing

Resolved

Sigma engineering has identified the cause, and the issue is now resolved. Users will need to perform a hard refresh of their browser to see the fix take effect. We will conduct a root cause analysis (RCA) and publish our findings in a postmortem note on the Sigma Community site in the coming days.

Impacted Cloud Regions & Services: All Regions
User Experience: Workbooks should now load normally after a hard refresh or browser restart.

Incident Start Time: Approximately 08:30 UTC, August 4, 2026
Incident End Time: Approximately 10:42 UTC, August 4, 2026
Posted Aug 04, 2026 - 11:11 UTC

Investigating

We are investigating an issue where workbooks containing a Snowflake Semantic View fail to load. Sigma Engineering is actively engaged as our highest priority. We apologize for any inconvenience caused.

Impacted Cloud Regions & Services: All Regions

User Experience: Workbook stuck in loading state when containing snowflake semantic views

Workarounds: None at this time

ETA: We do not have an ETA for resolution at this time. Updates will be provided as more information becomes available.

Incident Start Time: Approximately 08:30 UTC, August 4, 2026
Posted Aug 04, 2026 - 10:37 UTC