Workbooks with Input Tables failing to load and new Input Tables unable to be created
Incident Report for Sigma Computing
Postmortem

Sigma Engineering has completed the postmortem of this incident. A Root Cause Analysis (RCA) is available on the Sigma Community site: Postmortem for June 16, 2023 Workbooks with Input Tables failing to load Incident - Sigma AWS & Sigma GCP

Posted Jun 29, 2023 - 21:46 UTC

Resolved
Backdated Incident: Sigma users were unable to create new Input Tables and were unable to load existing workbooks if an Input Table was present in them. They encountered an error page stating: “cannot return null on non-nullable field ApiError.code”.
Impacted Cloud Regions & Services: All Sigma workbook users on all cloud regions who were using the Input Tables feature. Our engineers rapidly identified and fixed the root cause of this issue.

Incident Start Time: Jun 16, 2023 20:34 UTC
Incident End Time: Jun 16, 2023 21:05: UTC

We will perform a root cause analysis (RCA) and publish our findings in a postmortem note to the Sigma Community site in the coming days.
Posted Jun 16, 2023 - 20:30 UTC