Users Unable To Contact Live Chat Support
Incident Report for Sigma Computing
Resolved
Our third party chat service provider has resolved the issue that was causing users to not be able to contact our live support.
Posted Oct 12, 2023 - 16:04 UTC
Investigating
Our third party chat service is currently experiencing an incident. We are monitoring the status of the issue. In the meantime please reach out to support@sigmacomputing.com for any questions or inquiries.
Posted Oct 12, 2023 - 14:49 UTC