Missing search results from last 3 months affecting all Sigma deployments except AWS Canada
Incident Report for Sigma Computing
Postmortem

Sigma Engineering has completed the postmortem of this incident. A Root Cause Analysis (RCA) is available on the Sigma Community site: Postmortem for Sept 29, 2023 Incident: Missing search results from last 3 months affecting all Sigma deployments except AWS Canada

Posted Oct 24, 2023 - 20:15 UTC

Resolved
At approximately 1:44PM PDT (20:44 UTC), for Sigma users on all clouds excepting AWS Canada, search functionality within Sigma (home page search, datasource search and API search) were missing results from the last 3 months. This meant that Sigma application users may have been unable to find their documents, or saw older documents which no longer existed.

Users of embedded applications which use the Sigma search API may have experienced those applications loading incorrectly or failing to load.

Search results were brought back up to date as follows:
2:38 PM (21:38 UTC) - Azure eastus2 resolved
3:50 PM (22:50 UTC) - GCP us-central1 resolved
4:07 PM (23:07 UTC) - AWS us-west-2 resolved
4:17 PM (23:17 UTC) - AWS eu-central-1 resolved

Incident Start Time: 2023-09-29 20:44 UTC
Incident End Time: 2023-09-29 23:17 UTC

We will perform a root cause analysis (RCA) and publish our findings in a postmortem note to the Sigma Community site in coming days.
Posted Sep 29, 2023 - 20:30 UTC