Snowflake Tables Showing No data within Sigma but have a non-zero Row Count in Summary and Sigma SQL returns rows in Snowflake.
Incident Report for Sigma Computing
Postmortem

Sigma Engineering has completed the postmortem of this incident. A Root Cause Analysis (RCA) is available on the Sigma Community site: Post Mortem for Aug 29, 2023: Tables sourced from Snowflake appeared empty, displaying “No Data” message.

Posted Sep 09, 2023 - 00:43 UTC

Resolved
The Snowflake rollback has proven effective and the issue is resolved. Impacted Customers are no longer seeing the issue.

Incident Start Time: Approximately 3:40 UTC Aug 29, 2023
Incident End Time: Approximately 03:26 UTC Aug 31, 2023

We will perform a root cause analysis (RCA) and publish our findings in a postmortem note to the Sigma Community site in coming days. You will receive a notification when that occurs.
Posted Aug 31, 2023 - 18:05 UTC
Update
Snowflake has rolled back the changes for Impacted Customers and we have heard back that the issue is now resolved for our Impacted Customers. We are continuing to monitor the situation.
Posted Aug 31, 2023 - 16:28 UTC
Monitoring
Snowflake has acknowledged the issue and has rolled back the server changes for one of the affected customers. We're awaiting the rollback for the other affected customers. We'll keep you updated on our progress.
Posted Aug 31, 2023 - 14:17 UTC
Update
We're in direct collaboration with Snowflake to address this critical issue. Additionally, we're conducting thorough investigations on our end as we haven't ruled out the possibility of this being an issue within our code.

Rest assured, we're leaving no stone unturned as we explore both avenues for a swift resolution. Your patience is greatly appreciated.
Posted Aug 31, 2023 - 00:32 UTC
Update
Engineering is actively working on incorporating the most recent Snowflake driver code into Sigma, aiming for it to handle the variation in payload format we are observing for impacted customers.
Posted Aug 30, 2023 - 16:13 UTC
Update
Engineering has found what appear to be incomplete payloads being returned from the Snowflake data warehouse for the impacted customers. We believe this may be a result of a change that might have happened in the Snowflake environment and continue to work with Snowflake to root cause and identify a fix.
Posted Aug 30, 2023 - 07:40 UTC
Update
Our engineering team is actively investigating the Snowflake driver interface, focusing on analyzing Snowflake responses and checking driver version compatibility.
Thank you for your patience and understanding as we work through this matter. We are committed to swiftly resolving this issue and will keep you informed about the progress.
If you have any immediate concerns or questions, please feel free to reach out to our support team.
Posted Aug 30, 2023 - 04:21 UTC
Update
Engineering is continuing to investigate this issue, which we have isolated to the fetching of results from Snowflake. We are engaging with Snowflake Engineering to look into possible changes which might explain why results are not fetching as expected.
Posted Aug 30, 2023 - 01:50 UTC
Identified
We are currently investigating an issue that’s occurring for a small number of Snowflake customers where Tables are showing No Data but have the non-zero row count in the Summary.
This issue is being treated with the highest priority and we will update the status accordingly.

User Experience: Workbook elements are showing No Data and their source connection table is showing No Data but has row count in the Summary. Sigma SQL however returns results when run directly within Snowflake.

Impacted Cloud Regions & Services: Sigma organizations hosted across Clouds.

Incident Start Time: Approximately 3:40 UTC Aug 29, 2023
Posted Aug 30, 2023 - 00:08 UTC
This incident affected: GCP (Sigma - GCP (US)), AWS (Sigma - AWS (Europe), Sigma - AWS (US), Sigma - AWS (Canada)), and Azure (Sigma - Azure (US)).